<!DOCTYPE html>
<html prefix="og: http://ogp.me/ns#" lang="en-GB" dir="ltr">
<head>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<script src="/cdn-cgi/apps/head/0mE22UjC73jcMRwjumUIC1lFM_I.js"></script><link rel="icon" type="image/x-icon" href="/images/9999.PNG" />
<meta charset="utf-8" />
<base href="https://mibiz.com/sections/real-estate-development/kent-county-commissioners-vote-to-dissolve-land-bank" />
<meta name="keywords" content="Kent County Land Bank Authority,Kent County" />
<meta name="rights" content="Mibiz" />
<meta name="title" content="Kent County commissioners vote to dissolve Land Bank" />
<meta name="author" content="Sydney Smith" />
<meta property="og:url" content="https://mibiz.com/sections/real-estate-development/kent-county-commissioners-vote-to-dissolve-land-bank" />
<meta property="og:title" content="Kent County commissioners vote to dissolve Land Bank - MiBiz: West Michigan Business News" />
<meta property="og:type" content="article" />
<meta property="og:description" content="GRAND RAPIDS — To the disappointment of executives and several nonprofits present, the Kent County Board of Commissioners voted today to dissolve the..." />
<meta name="description" content="GRAND RAPIDS — To the disappointment of executives and several nonprofits present, the Kent County Board of Commissioners voted today to dissolve the..." />
<meta name="generator" content="Joomla! - Open Source Content Management" />
<title>Kent County commissioners vote to dissolve Land Bank - MiBiz: West Michigan Business News</title>
<link href="https://cdnjs.cloudflare.com/ajax/libs/magnific-popup.js/1.1.0/magnific-popup.min.css" rel="stylesheet" />
<link href="https://cdnjs.cloudflare.com/ajax/libs/simple-line-icons/2.4.1/css/simple-line-icons.min.css" rel="stylesheet" />
<link href="/components/com_k2/css/k2.css?v=2.9.0" rel="stylesheet" />
<link href="/media/jui/css/chosen.css?33754512d7f4fdb9f0cf093f44ece24c" rel="stylesheet" />
<link href="/media/com_finder/css/finder.css?33754512d7f4fdb9f0cf093f44ece24c" rel="stylesheet" />
<link href="/media/gantry5/assets/css/font-awesome.min.css?5c13ed40" rel="stylesheet" />
<link href="/media/gantry5/engines/nucleus/css-compiled/nucleus.css?5c13ed40" rel="stylesheet" />
<link href="/templates/rt_denali/custom/css-compiled/denali_232.css?5c13ed43" rel="stylesheet" />
<link href="/media/gantry5/assets/css/bootstrap-gantry.css?5c13ed40" rel="stylesheet" />
<link href="/media/gantry5/engines/nucleus/css-compiled/joomla.css?5c13ed40" rel="stylesheet" />
<link href="/media/jui/css/icomoon.css" rel="stylesheet" />
<link href="/templates/rt_denali/custom/css-compiled/denali-joomla_232.css?5c13ed43" rel="stylesheet" />
<link href="/templates/rt_denali/custom/css-compiled/custom_232.css?5c13ed43" rel="stylesheet" />
<link href="/templates/rt_denali/custom/css-compiled/engine-custom_232.css?5c13ed44" rel="stylesheet" />
<style>

						/* K2 - Magnific Popup Overrides */
						.mfp-iframe-holder {padding:10px;}
						.mfp-iframe-holder .mfp-content {max-width:100%;width:100%;height:100%;}
						.mfp-iframe-scaler iframe {background:#fff;padding:10px;box-sizing:border-box;box-shadow:none;}
					
	</style>
<script type="application/json" class="joomla-script-options new">{"csrf.token":"e5f76e9375deb961650d7ec04e676431","system.paths":{"root":"","base":""},"system.keepalive":{"interval":840000,"uri":"\/component\/ajax\/?format=json"}}</script>
<script src="/media/jui/js/jquery.min.js?33754512d7f4fdb9f0cf093f44ece24c"></script>
<script src="/media/jui/js/jquery-noconflict.js?33754512d7f4fdb9f0cf093f44ece24c"></script>
<script src="/media/jui/js/jquery-migrate.min.js?33754512d7f4fdb9f0cf093f44ece24c"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/magnific-popup.js/1.1.0/jquery.magnific-popup.min.js"></script>
<script src="/media/k2/assets/js/k2.frontend.js?v=2.9.0&amp;sitepath=/"></script>
<script src="/media/plg_jchoptimize/js/pro-jquery.lazy.js"></script>
<script src="/media/jui/js/chosen.jquery.min.js?33754512d7f4fdb9f0cf093f44ece24c"></script>
<script src="/media/jui/js/bootstrap.min.js?33754512d7f4fdb9f0cf093f44ece24c"></script>
<script src="/media/jui/js/jquery.autocomplete.min.js?33754512d7f4fdb9f0cf093f44ece24c"></script>
<script src="/media/system/js/core.js?33754512d7f4fdb9f0cf093f44ece24c"></script>
<!--[if lt IE 9]><script src="/media/system/js/polyfill.event.js?33754512d7f4fdb9f0cf093f44ece24c"></script><![endif]-->
<script src="/media/system/js/keepalive.js?33754512d7f4fdb9f0cf093f44ece24c"></script>
<script src="/media/jui/js/jquery.ui.core.min.js?33754512d7f4fdb9f0cf093f44ece24c"></script>
<script src="/media/jui/js/jquery.ui.sortable.min.js?33754512d7f4fdb9f0cf093f44ece24c"></script>
<script src="/templates/rt_denali/custom/js/custom.js"></script>
<script>


jQuery(function() {
	jQuery('img[data-jchll=true]').lazy();
});

	jQuery(function ($) {
		initChosen();
		$("body").on("subform-row-add", initChosen);

		function initChosen(event, container)
		{
			container = container || document;
			$(container).find(".advancedSelect").chosen({"disable_search_threshold":10,"search_contains":true,"allow_single_deselect":true,"placeholder_text_multiple":"Type or select some options","placeholder_text_single":"Select an option","no_results_text":"No results match"});
		}
	});
	jQuery(function($){ initTooltips(); $("body").on("subform-row-add", initTooltips); function initTooltips (event, container) { container = container || document;$(container).find(".hasTooltip").tooltip({"html": true,"container": "body"});} });
jQuery(document).ready(function() {
	var value, searchword = jQuery('#mod-finder-searchword640');

		// Get the current value.
		value = searchword.val();

		// If the current value equals the default value, clear it.
		searchword.on('focus', function ()
		{
			var el = jQuery(this);

			if (el.val() === 'Search ...')
			{
				el.val('');
			}
		});

		// If the current value is empty, set the previous value.
		searchword.on('blur', function ()
		{
			var el = jQuery(this);

			if (!el.val())
			{
				el.val(value);
			}
		});

		jQuery('#mod-finder-searchform640').on('submit', function (e)
		{
			e.stopPropagation();
			var advanced = jQuery('#mod-finder-advanced640');

			// Disable select boxes with no value selected.
			if (advanced.length)
			{
				advanced.find('select').each(function (index, el)
				{
					var el = jQuery(el);

					if (!el.val())
					{
						el.attr('disabled', 'disabled');
					}
				});
			}
		});
	var suggest = jQuery('#mod-finder-searchword640').autocomplete({
		serviceUrl: '/component/finder/?task=suggestions.suggest&amp;format=json&amp;tmpl=component',
		paramName: 'q',
		minChars: 1,
		maxHeight: 400,
		width: 300,
		zIndex: 9999,
		deferRequestBy: 500
	});});
	</script>

<script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "Organization",
    "url": "https://mibiz.com",
    "logo": "https://mibiz.com/images/MiBizLogo.PNG"
}
</script>
<script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "Organization",
    "name": "MiBiz - West Michigan Business News",
    "url": "https://mibiz.com",
    "sameAs": [
        "https://www.facebook.com/MiBiz-32340683364/",
        "https://twitter.com/mibiz",
        "https://www.linkedin.com/company/mibiz/"
    ]
}
</script>
<script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "item": {
                "@id": "https://mibiz.com/",
                "name": "Home"
            }
        },
        {
            "@type": "ListItem",
            "position": 2,
            "item": {
                "@id": "https://mibiz.com/sections/real-estate-development",
                "name": "Real Estate/Development"
            }
        },
        {
            "@type": "ListItem",
            "position": 3,
            "item": {
                "@id": "https://mibiz.com/sections/real-estate-development/kent-county-commissioners-vote-to-dissolve-land-bank",
                "name": "Kent County commissioners vote to dissolve Land Bank"
            }
        }
    ]
}
</script>

<!--[if (gte IE 8)&(lte IE 9)]>
        <script type="text/javascript" src="/media/gantry5/assets/js/html5shiv-printshiv.min.js?5c13ed40"></script>
        <link rel="stylesheet" href="/media/gantry5/engines/nucleus/css/nucleus-ie9.css?5c13ed40" type="text/css"/>
        <script type="text/javascript" src="/media/gantry5/assets/js/matchmedia.polyfill.js?5c13ed40"></script>
        <![endif]-->
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#property=5ba945ca570347001195269e&product=inline-share-buttons' async='async'>
</script>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
$(window).on('load', function(){
  setTimeout(removeLoader, 2000); //wait for page load PLUS two seconds.
});
function removeLoader(){
    $( "#loadingDiv" ).fadeOut(500, function() {
      // fadeOut complete. Remove the loading div
      $( "#loadingDiv" ).remove(); //makes page more lightweight 
  });  
}
</script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/47981962/MIBIZ/MIBIZ_IN-D', [640, 480], 'div-gpt-ad-1537797236784-0').addService(googletag.pubads());
    googletag.defineSlot('/47981962/MIBIZ/MIBIZ_IN-M', [300, 400], 'div-gpt-ad-1537797394994-0').addService(googletag.pubads());
    googletag.defineSlot('/47981962/MIBIZ/MIBIZ_LR1', [300, 250], 'div-gpt-ad-1537797678702-0').addService(googletag.pubads());
    googletag.defineSlot('/47981962/MIBIZ/MIBIZ_L1-D', [728, 90], 'div-gpt-ad-1537797743484-0').addService(googletag.pubads());
    googletag.defineSlot('/47981962/MIBIZ/MIBIZ_L1-M', [300, 250], 'div-gpt-ad-1537797820946-0').addService(googletag.pubads());
    googletag.defineSlot('/47981962/MIBIZ/MIBIZ_LR2', [300, 250], 'div-gpt-ad-1537797923370-0').addService(googletag.pubads());
    googletag.defineSlot('/47981962/MIBIZ/MIBIZ_L2-D', [728, 90], 'div-gpt-ad-1537798024732-0').addService(googletag.pubads());
    googletag.defineSlot('/47981962/MIBIZ/MIBIZ_L2-M', [300, 250], 'div-gpt-ad-1537798114714-0').addService(googletag.pubads());
    googletag.defineSlot('/47981962/MIBIZ/MIBIZ_XR1', [[300, 100], [300, 250]], 'div-gpt-ad-1537798190336-0').addService(googletag.pubads());
    googletag.defineSlot('/47981962/MIBIZ/MIBIZ_XR2', [[300, 100], [300, 250]], 'div-gpt-ad-1540610139465-0').addService(googletag.pubads());
    googletag.defineSlot('/47981962/MIBIZ/MIBIZ_XR3', [[300, 100], [300, 250]], 'div-gpt-ad-1537798612257-0').addService(googletag.pubads());
    googletag.defineSlot('/47981962/MIBIZ/MIBIZ_XR4', [[300, 100], [300, 250]], 'div-gpt-ad-1537798853340-0').addService(googletag.pubads());
    googletag.defineSlot('/47981962/MIBIZ/MIBIZ_XR5', [[300, 100], [300, 250]], 'div-gpt-ad-1537799125700-0').addService(googletag.pubads());
    googletag.defineSlot('/47981962/MIBIZ/MIBIZ_XR6', [[300, 100], [300, 250]], 'div-gpt-ad-1537799308822-0').addService(googletag.pubads());
    googletag.defineSlot('/47981962/MIBIZ/MIBIZ_XR7', [[300, 100], [300, 250]], 'div-gpt-ad-1537799376570-0').addService(googletag.pubads());
    googletag.defineSlot('/47981962/MIBIZ/MIBIZ_XR8', [[300, 100], [300, 250]], 'div-gpt-ad-1540612011392-0').addService(googletag.pubads());
    googletag.defineSlot('/47981962/MIBIZ/MIBIZ_XR9', [[300, 100], [300, 250]], 'div-gpt-ad-1540611664178-0').addService(googletag.pubads());
    googletag.defineSlot('/47981962/MIBIZ/MIBIZ_XR10', [[300, 100], [300, 250]], 'div-gpt-ad-1540611828618-0').addService(googletag.pubads());
googletag.defineSlot('/47981962/MIBIZ/MIBIZ_NLR_MEDICAL', [[300, 100], [300, 250]], 'div-gpt-ad-1537799881425-0').addService(googletag.pubads());
   googletag.defineSlot('/47981962/MIBIZ/MIBIZ_NLR_FOODAGRI', [[300, 250], [300, 100]], 'div-gpt-ad-1539801928564-0').addService(googletag.pubads());
 googletag.defineSlot('/47981962/MIBIZ/MIBIZ_NLR_MANUFACTURING', [[300, 100], [300, 250]], 'div-gpt-ad-1539801950868-0').addService(googletag.pubads());
   googletag.defineSlot('/47981962/MIBIZ/MIBIZ_NLR_NONPROFITS', [[300, 100], [300, 250]], 'div-gpt-ad-1539801972984-0').addService(googletag.pubads());
   googletag.defineSlot('/47981962/MIBIZ/MIBIZ_NLR_ENERGY', [[300, 100], [300, 250]], 'div-gpt-ad-1539801889445-0').addService(googletag.pubads());
   googletag.pubads().enableSingleRequest();
   googletag.pubads().collapseEmptyDivs();
   googletag.enableServices();
  });
</script>
<script>
function setCookie(name,value,miniutes) {
    var expires = "";
    if (miniutes) {
        var date = new Date();
        date.setTime(date.getTime() + (miniutes*60*1000));
        expires = "; expires=" + date.toUTCString();
    }
    document.cookie = name + "=" + (value || "")  + expires + ";domain=.mibiz.com;path=/";
}
function getCookie(name) {
    var nameEQ = name + "=";
    var ca = document.cookie.split(';');
    for(var i=0;i < ca.length;i++) {
        var c = ca[i];
        while (c.charAt(0)==' ') c = c.substring(1,c.length);
        if (c.indexOf(nameEQ) == 0) return c.substring(nameEQ.length,c.length);
    }
    return null;
}
function eraseCookie(name) {   
    document.cookie = name+'=; Max-Age=-66669999;';  
}
</script>
<noscript>
                        <style type="text/css">
                                img[data-jchll=true]{
                                        display: none;
                                }                               
                        </style>                                
                </noscript>
</head>
<body class="gantry site com_k2 view-item no-layout no-task dir-ltr itemid-324 outline-232 g-offcanvas-left g-default g-style-preset1">
<div id="g-offcanvas" data-g-offcanvas-swipe="0" data-g-offcanvas-css3="1">
<div class="g-grid">
<div class="g-block size-100">
<div id="mobile-menu-1768-particle" class="g-content g-particle"> <div id="g-mobilemenu-container" data-g-menu-breakpoint="2048px"></div>
</div>
</div>
</div>
</div>
<div id="g-page-surround">
<div class="g-offcanvas-hide g-offcanvas-toggle" data-offcanvas-toggle aria-controls="g-offcanvas" aria-expanded="false"><i class="fa fa-fw fa-bars"></i></div>
<section id="g-top" class="section-horizontal-paddings">
<div class="g-grid">
<div class="g-block size-100">
<div class="g-system-messages">
</div>
</div>
</div>
</section>
<section id="g-TopBar">
<div class="g-grid">
<div class="g-block size-5">
<div id="custom-4003-particle" class="g-content g-particle"> <a href="/search-result"><div class="icon-search icon-white"></div></a>
</div>
</div>
<div class="g-block size-45">
<div class="g-content">
<div class="platform-content"><div class="moduletable ">
<form id="mod-finder-searchform640" action="/search-result" method="get" class="form-search">
<div class="finder">
<label for="mod-finder-searchword640" class="element-invisible finder">Search</label><input type="text" name="q" id="mod-finder-searchword640" class="search-query input-medium" size="25" value="" placeholder="Search ..." />
</div>
</form>
</div></div>
</div>
</div>
 <div id="welcomeText" class="g-block size-50">
<div class="g-content">
<div class="platform-content"><div class="moduletable ">
<div class="custom">
<button id="LoginButton" onclick="flipit()">Login</button></div>
</div></div>
</div>
</div>
</div>
<div class="g-grid">
<div class="g-block size-100">
<div class="g-content">
<div class="platform-content"><div class="moduletable ">
<form action="/sections/real-estate-development" method="post" id="login-form" class="form-inline">
<div class="userdata">
<div id="form-login-username" class="control-group">
<div class="controls">
<div class="input-prepend">
<span class="add-on">
<span class="icon-user hasTooltip" title="Username"></span>
<label for="modlgn-username" class="element-invisible">Username</label>
</span>
<input id="modlgn-username" type="text" name="username" class="input-small" tabindex="0" size="18" placeholder="Username" />
</div>
</div>
</div>
<div id="form-login-password" class="control-group">
<div class="controls">
<div class="input-prepend">
<span class="add-on">
<span class="icon-lock hasTooltip" title="Password">
</span>
<label for="modlgn-passwd" class="element-invisible">Password </label>
</span>
<input id="modlgn-passwd" type="password" name="password" class="input-small" tabindex="0" size="18" placeholder="Password" />
</div>
</div>
</div>
<div id="form-login-remember" class="control-group checkbox">
<label for="modlgn-remember" class="control-label">Remember Me</label> <input id="modlgn-remember" type="checkbox" name="remember" class="inputbox" value="yes" />
</div>
<div id="form-login-submit" class="control-group">
<div class="controls">
<button type="submit" tabindex="0" name="Submit" class="btn btn-primary login-button">Log in</button>
</div>
</div>
<ul class="unstyled">
<li>
<a href="/component/users/?view=remind&amp;Itemid=101">
Forgot your username?</a>
</li>
<li>
<a href="/component/users/?view=reset&amp;Itemid=101">
Forgot your password?</a>
</li>
</ul>
<input type="hidden" name="option" value="com_users" />
<input type="hidden" name="task" value="user.login" />
<input type="hidden" name="return" value="aHR0cHM6Ly9taWJpei5jb20vc2VjdGlvbnMvcmVhbC1lc3RhdGUtZGV2ZWxvcG1lbnQva2VudC1jb3VudHktY29tbWlzc2lvbmVycy12b3RlLXRvLWRpc3NvbHZlLWxhbmQtYmFuaw==" />
<input type="hidden" name="e5f76e9375deb961650d7ec04e676431" value="1" /> </div>
</form>
</div></div>
</div>
</div>
</div>
</section>
<section id="g-navigation">
<div class="g-grid">
<div id="mrburger" class="g-block size-10">
<div id="mobile-menu-8661-particle" class="g-content g-particle"> <div id="g-mobilemenu-container" data-g-menu-breakpoint="2048px"></div>
</div>
</div>
<div class="g-block size-27">
<div class="spacer"></div>
</div>
<div id="logo" class="g-block size-30 denali-logo">
<div id="logo-5737-particle" class="g-content g-particle"> <a href="/" target="_self" title="Denali" rel="home" class="g-logo">
<img src="/images/MiBizLogo.PNG" alt="denali&lt;span&gt;.&lt;/span&gt;" />
</a>
</div>
</div>
<div class="g-block size-33 align-right flush">
<div id="social-3622-particle" class="g-content g-particle"> <div class="g-social ">
<div class="g-social-items">
<a target="_blank" href="https://www.facebook.com/MiBiz-32340683364/" title="" aria-label="" rel="noopener noreferrer">
<span class="fa fa-facebook-square fa-fw"></span> <span class="g-social-text"></span> </a>
<a target="_blank" href="https://twitter.com/mibiz" title="" aria-label="" rel="noopener noreferrer">
<span class="fa fa-twitter-square fa-fw"></span> <span class="g-social-text"></span> </a>
<a target="_blank" href="https://www.linkedin.com/company/mibiz/" title="" aria-label="" rel="noopener noreferrer">
<span class="fa fa-linkedin-square fa-fw"></span> <span class="g-social-text"></span> </a>
</div>
</div>
</div>
</div>
</div>
<div class="g-grid">
<div id="nav" class="g-block size-100 center">
<div id="menu-9170-particle" class="g-content g-particle"> <nav class="g-main-nav" role="navigation" data-g-mobile-target data-g-hover-expand="true">
<ul class="g-toplevel">
<li class="g-menu-item g-menu-item-type-component g-menu-item-101 g-standard  ">
<a class="g-menu-item-container" href="/">
<span class="g-menu-item-content">
<span class="g-menu-item-title">MiBiz</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-heading g-menu-item-249 g-parent active g-standard  ">
<div class="g-menu-item-container" data-g-menuparent=""> <span class="g-nav-header g-menu-item-content"> <span class="g-menu-item-title">SECTIONS</span>
</span>
<span class="g-menu-parent-indicator"></span> </div> <ul class="g-dropdown g-inactive g-fade g-dropdown-right">
<li class="g-dropdown-column">
<div class="g-grid">
<div class="g-block size-100">
<ul class="g-sublevel">
<li class="g-level-1 g-go-back">
<a class="g-menu-item-container" href="#" data-g-menuparent=""><span>Back</span></a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-399  ">
<a class="g-menu-item-container" href="/sections/breaking-news">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Breaking News</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-328  ">
<a class="g-menu-item-container" href="/sections/economic-development">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Economic Development</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-322  ">
<a class="g-menu-item-container" href="/sections/finance">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Finance</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-323  ">
<a class="g-menu-item-container" href="/sections/food-agribusiness">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Food/Agribusiness</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-329  ">
<a class="g-menu-item-container" href="/sections/health-care">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Health Care</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-326  ">
<a class="g-menu-item-container" href="/sections/manufacturing">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Manufacturing</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-327  ">
<a class="g-menu-item-container" href="/sections/nonprofits">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Nonprofits</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-324 active  ">
<a class="g-menu-item-container" href="/sections/real-estate-development">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Real Estate/Development</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-398  ">
<a class="g-menu-item-container" href="/sections/small-business">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Small Business</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-428  ">
<a class="g-menu-item-container" href="/sections/energy">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Energy</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-325  ">
<a class="g-menu-item-container" href="/sections/talent">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Talent</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-330  ">
<a class="g-menu-item-container" href="/sections/other">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Other</span>
</span>
</a>
</li>
</ul>
</div>
</div>
</li>
</ul>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-250 g-standard  ">
<a class="g-menu-item-container" href="/events">
<span class="g-menu-item-content">
<span class="g-menu-item-title">EVENTS</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-251 g-parent g-standard g-menu-item-link-parent ">
<a class="g-menu-item-container" href="/advertise">
<span class="g-menu-item-content">
<span class="g-menu-item-title">ADVERTISE </span>
</span>
<span class="g-menu-parent-indicator" data-g-menuparent=""></span> </a>
<ul class="g-dropdown g-inactive g-fade g-dropdown-right">
<li class="g-dropdown-column">
<div class="g-grid">
<div class="g-block size-100">
<ul class="g-sublevel">
<li class="g-level-1 g-go-back">
<a class="g-menu-item-container" href="#" data-g-menuparent=""><span>Back</span></a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-349  ">
<a class="g-menu-item-container" href="/advertise/reader-demographics">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Reader Demographics</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-350  ">
<a class="g-menu-item-container" href="/advertise/editorial-calendar">
 <span class="g-menu-item-content">
<span class="g-menu-item-title">Editorial Calendar</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-352  ">
<a class="g-menu-item-container" href="/advertise/request-rates">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Request Rates</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-353  ">
<a class="g-menu-item-container" href="/advertise/special-supplements">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Special Supplements</span>
</span>
</a>
</li>
</ul>
</div>
</div>
</li>
</ul>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-253 g-parent g-standard g-menu-item-link-parent ">
<a class="g-menu-item-container" href="/subscribe">
<span class="g-menu-item-content">
<span class="g-menu-item-title">SUBSCRIBE</span>
</span>
<span class="g-menu-parent-indicator" data-g-menuparent=""></span> </a>
<ul class="g-dropdown g-inactive g-fade g-dropdown-right">
<li class="g-dropdown-column">
<div class="g-grid">
<div class="g-block size-100">
<ul class="g-sublevel">
<li class="g-level-1 g-go-back">
<a class="g-menu-item-container" href="#" data-g-menuparent=""><span>Back</span></a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-388  ">
<a class="g-menu-item-container" href="/subscribe/subscription-questions">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Subscription Questions</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-387  ">
<a class="g-menu-item-container" href="/subscribe/e-newsletters">
<span class="g-menu-item-content">
<span class="g-menu-item-title">E-Newsletters</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-385  ">
<a class="g-menu-item-container" href="/subscribe/newsstand-sales">
 <span class="g-menu-item-content">
<span class="g-menu-item-title">Newsstand Sales</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-alias g-menu-item-397  ">
<a class="g-menu-item-container" href="/subscribe">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Subscribe</span>
</span>
</a>
</li>
</ul>
</div>
</div>
</li>
</ul>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-354 g-parent g-standard g-menu-item-link-parent ">
<a class="g-menu-item-container" href="/contact">
<span class="g-menu-item-content">
<span class="g-menu-item-title">CONTACT</span>
</span>
<span class="g-menu-parent-indicator" data-g-menuparent=""></span> </a>
<ul class="g-dropdown g-inactive g-fade g-dropdown-right">
<li class="g-dropdown-column">
<div class="g-grid">
<div class="g-block size-100">
<ul class="g-sublevel">
<li class="g-level-1 g-go-back">
<a class="g-menu-item-container" href="#" data-g-menuparent=""><span>Back</span></a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-355  ">
<a class="g-menu-item-container" href="/contact/staff">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Staff</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-356  ">
<a class="g-menu-item-container" href="/contact/locations">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Locations</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-alias g-menu-item-403  ">
<a class="g-menu-item-container" href="/careers">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Careers</span>
</span>
</a>
</li>

</ul>
</div>
</div>
</li>
</ul>
</li>
</ul>
</nav>
</div>
</div>
</div>
<div class="g-grid">
<div id="menu-main" class="g-block size-100 center">
<div id="menu-7856-particle" class="g-content g-particle"> <nav class="g-main-nav" role="navigation" data-g-hover-expand="true">
<ul class="g-toplevel">
<li class="g-menu-item g-menu-item-type-component g-menu-item-101 g-standard  ">
<a class="g-menu-item-container" href="/">
<span class="g-menu-item-content">
<span class="g-menu-item-title">MiBiz</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-heading g-menu-item-249 g-parent active g-standard  ">
<div class="g-menu-item-container" data-g-menuparent=""> <span class="g-nav-header g-menu-item-content"> <span class="g-menu-item-title">SECTIONS</span>
</span>
<span class="g-menu-parent-indicator"></span> </div> <ul class="g-dropdown g-inactive g-fade g-dropdown-right">
<li class="g-dropdown-column">
<div class="g-grid">
<div class="g-block size-100">
<ul class="g-sublevel">
<li class="g-level-1 g-go-back">
<a class="g-menu-item-container" href="#" data-g-menuparent=""><span>Back</span></a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-399  ">
<a class="g-menu-item-container" href="/sections/breaking-news">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Breaking News</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-328  ">
<a class="g-menu-item-container" href="/sections/economic-development">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Economic Development</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-322  ">
<a class="g-menu-item-container" href="/sections/finance">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Finance</span>
</span>
</a>
</li>

<li class="g-menu-item g-menu-item-type-component g-menu-item-323  ">
<a class="g-menu-item-container" href="/sections/food-agribusiness">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Food/Agribusiness</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-329  ">
<a class="g-menu-item-container" href="/sections/health-care">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Health Care</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-326  ">
<a class="g-menu-item-container" href="/sections/manufacturing">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Manufacturing</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-327  ">
<a class="g-menu-item-container" href="/sections/nonprofits">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Nonprofits</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-324 active  ">
<a class="g-menu-item-container" href="/sections/real-estate-development">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Real Estate/Development</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-398  ">
<a class="g-menu-item-container" href="/sections/small-business">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Small Business</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-428  ">
<a class="g-menu-item-container" href="/sections/energy">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Energy</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-325  ">
<a class="g-menu-item-container" href="/sections/talent">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Talent</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-330  ">
<a class="g-menu-item-container" href="/sections/other">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Other</span>
</span>
</a>
</li>
</ul>
</div>
</div>
</li>
</ul>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-250 g-standard  ">
<a class="g-menu-item-container" href="/events">
<span class="g-menu-item-content">
<span class="g-menu-item-title">EVENTS</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-251 g-parent g-standard g-menu-item-link-parent ">
<a class="g-menu-item-container" href="/advertise">
<span class="g-menu-item-content">
<span class="g-menu-item-title">ADVERTISE </span>
</span>
<span class="g-menu-parent-indicator" data-g-menuparent=""></span> </a>
<ul class="g-dropdown g-inactive g-fade g-dropdown-right">
<li class="g-dropdown-column">
<div class="g-grid">
<div class="g-block size-100">
<ul class="g-sublevel">
<li class="g-level-1 g-go-back">
<a class="g-menu-item-container" href="#" data-g-menuparent=""><span>Back</span></a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-349  ">
<a class="g-menu-item-container" href="/advertise/reader-demographics">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Reader Demographics</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-350  ">
<a class="g-menu-item-container" href="/advertise/editorial-calendar">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Editorial Calendar</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-352  ">
<a class="g-menu-item-container" href="/advertise/request-rates">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Request Rates</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-353  ">
<a class="g-menu-item-container" href="/advertise/special-supplements">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Special Supplements</span>
</span>
</a>
</li>
</ul>
</div>
</div>
</li>
</ul>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-253 g-parent g-standard g-menu-item-link-parent ">
<a class="g-menu-item-container" href="/subscribe">
<span class="g-menu-item-content">
<span class="g-menu-item-title">SUBSCRIBE</span>
</span>
<span class="g-menu-parent-indicator" data-g-menuparent=""></span> </a>
<ul class="g-dropdown g-inactive g-fade g-dropdown-right">
<li class="g-dropdown-column">
<div class="g-grid">
<div class="g-block size-100">
<ul class="g-sublevel">
<li class="g-level-1 g-go-back">
<a class="g-menu-item-container" href="#" data-g-menuparent=""><span>Back</span></a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-388  ">
<a class="g-menu-item-container" href="/subscribe/subscription-questions">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Subscription Questions</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-387  ">
<a class="g-menu-item-container" href="/subscribe/e-newsletters">
<span class="g-menu-item-content">
<span class="g-menu-item-title">E-Newsletters</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-385  ">
<a class="g-menu-item-container" href="/subscribe/newsstand-sales">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Newsstand Sales</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-alias g-menu-item-397  ">
 <a class="g-menu-item-container" href="/subscribe">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Subscribe</span>
</span>
</a>
</li>
</ul>
</div>
</div>
</li>
</ul>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-354 g-parent g-standard g-menu-item-link-parent ">
<a class="g-menu-item-container" href="/contact">
<span class="g-menu-item-content">
<span class="g-menu-item-title">CONTACT</span>
</span>
<span class="g-menu-parent-indicator" data-g-menuparent=""></span> </a>
<ul class="g-dropdown g-inactive g-fade g-dropdown-right">
<li class="g-dropdown-column">
<div class="g-grid">
<div class="g-block size-100">
<ul class="g-sublevel">
<li class="g-level-1 g-go-back">
<a class="g-menu-item-container" href="#" data-g-menuparent=""><span>Back</span></a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-355  ">
<a class="g-menu-item-container" href="/contact/staff">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Staff</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-component g-menu-item-356  ">
<a class="g-menu-item-container" href="/contact/locations">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Locations</span>
</span>
</a>
</li>
<li class="g-menu-item g-menu-item-type-alias g-menu-item-403  ">
<a class="g-menu-item-container" href="/careers">
<span class="g-menu-item-content">
<span class="g-menu-item-title">Careers</span>
</span>
</a>
</li>
</ul>
</div>
</div>
</li>
</ul>
</li>
</ul>
</nav>
</div>
</div>
</div>
</section>
<section id="g-feature">
 <div class="g-grid">
<div id="Ad-1" class="g-block size-100">
<div class="g-content">
<div class="moduletable ">
<div class="clearfix ">

<div id='div-gpt-ad-1537797743484-0' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1537797743484-0'); });
</script>
</div></p>
</div> </div>
</div>
</div>
</div>
</section>
<section id="g-container-main" class="g-wrapper">
<div class="g-grid">
<div class="g-block size-75">
<section id="g-Wrapper">
<div class="g-grid">
<div class="g-block size-100">
<main id="g-mainbar">
<div class="g-grid">
<div class="g-block size-100">
<div class="g-content">
<div class="platform-content row-fluid"><div class="span12">
<span id="startOfPageId26393"></span>
<div id="k2Container" class="itemView itemIsFeatured">


<div class="itemHeader">

<div class="itemCategory">
<span>Published in</span>
<a href="/sections/real-estate-development">Real Estate/Development</a>
</div>

<h1 class="itemTitle">
Kent County commissioners vote to dissolve Land Bank
</h1>

<span class="itemAuthor">
BY <a rel="author" href="/contact/sydney-smith">Sydney Smith</a>
</span>

<span class="itemDateCreated">
Thursday, December 20, 2018 02:21pm </span>
</div>


<div class="itemToolbar">
<ul>

<li>
<span class="itemTextResizerTitle">font size</span>
<a href="#" id="fontDecrease">
<span>decrease font size</span>
</a>
<a href="#" id="fontIncrease">
<span>increase font size</span>
</a>
</li>

<li>
<a class="itemPrintLink" rel="nofollow" href="/sections/real-estate-development/kent-county-commissioners-vote-to-dissolve-land-bank?tmpl=component&amp;print=1" onclick="window.open(this.href,'printWindow','width=900,height=600,location=no,menubar=no,resizable=yes,scrollbars=yes'); return false;">
<span>Print</span>
</a>
</li>

<li>
<a class="itemEmailLink" rel="nofollow" href="/component/mailto/?tmpl=component&amp;template=rt_denali&amp;link=435a40a5925b3abb629ffde1b4877524aa660a3f" onclick="window.open(this.href,'emailWindow','width=400,height=350,location=no,menubar=no,resizable=no,scrollbars=no'); return false;">
<span>Email</span>
</a>
</li>
</ul>
<div class="clr"></div>
</div>
<div class="itemBody">



<div class="itemFullText">
<div class="sharethis-inline-share-buttons"></div>
<p>GRAND RAPIDS — To the disappointment of executives and several nonprofits present, the Kent County Board of Commissioners voted today to dissolve the <strong>Kent County Land Bank Authority</strong>.
<p>Some commissioners cited issues of “mission creep” in voting 11-8 to withdraw from an intergovernmental agreement between the <strong>Michigan Land Bank Fast Track Authority</strong> and the county treasurer to dissolve the Land Bank, which will have 12 months to handle its liabilities and agreements before it concludes.
<p>“It is what it is now,” Ken Parrish, county treasurer and chair of the land bank authority, told <em>MiBiz</em>. “We have to figure out how we can move forward.”
<p>Parrish said the land bank authority will begin to take a status of projects it’s involved in, sell all of its property and pay off debts.
<p>Some ambiguity remains as to whether the Land Bank’s assets go to the state land bank or to Kent County, something Parrish said he needs to figure out in the coming months. <div class="moduletable">
<div class="custom">

<div id='div-gpt-ad-1537798190336-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1537798190336-0'); });
</script>
</div>
</div>
</div>
<p>During a lengthy discussion, some commissioners argued the Kent County Land Bank, founded in 2011, had fulfilled its original intent and was no longer needed because the real estate market had improved.
<p>However, representatives of nonprofits and advocates for affordable housing said otherwise, and asked the board to take a longer look before voting. In a Dec. 17 letter, the city of Grand Rapids also asked for the resolution to be tabled for more discussion.
<p>“It is a valuable tool that is available to governments to preserve affordable housing,” said Laurie Craft, vice president for community investment at the Grand Rapids Community Foundation. “It’s really disappointing that this decision is being brought up and voted on within a matter of days.”
<p>The resolution was recommended by the county finance committee on Dec. 18. <div class="moduletable">
<div class="custom">

<div id='div-gpt-ad-1540610139465-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540610139465-0'); });
</script>
</div></div>
</div>
<p>Commissioners who voted against the resolution argued more time was needed for review, but those who voted to dissolve the Land Bank said that had already been accomplished.
<p>In 2016, a subcommittee of commissioners reviewed the Land Bank and made recommendations on improvements, saying the body would be reviewed again in 2020. This year, staff from the county administrator’s office conducted an “implementation review” by interviewing stakeholders to see if those recommendations had been met.
<p>The move came as some commissioners questioned the mission of the Land Bank after its executive director, David Allen, rebranded the organization as <strong>Innova-Lab</strong> and partnered with <strong>Champion Homes Inc.</strong> to begin developing modular homes throughout Grand Rapids.
<p>According to Board of Commissioners Chair Jim Saalfeld, the Land Bank’s pivot demonstrated its unwillingness to work under the subcommittee’s recommendations. <div class="moduletable">
<div class="custom">

<div id='div-gpt-ad-1537798612257-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1537798612257-0'); });
</script>
</div>
</div>
</div>
<p>Saalfeld said his reason for voting to dissolve the Land Bank stemmed its fulfillment of its original mission to address blight in the county when the real estate market was in bad shape.
<p>“This is about a program we adopted in 2011,” he said. “It did its job, did it well, and we promised the citizens of Kent County at that time that we would close it down when it had done its job.”
<p>One commissioner questioned where nonprofits could go to get help in clearing titles, a key function of the Land Bank. Kent County Corporate Counsel Linda Howell said the action could be done in Circuit Court.
<p>The move does not prevent Kent County from establishing another land bank in the future. <div class="moduletable">
<div class="custom">

<div id='div-gpt-ad-1537798853340-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1537798853340-0'); });
</script>
</div>
</div>
</div>
<p>The intergovernmental agreement states that the disposition of remaining assets, including properties owned by the land bank authority, are subject to agreement between the county treasurer and the state authority.
<p>However, the Land Bank’s articles of incorporation specify that assets go to Kent County or to local units, if there are interlocal agreements requiring that. <div class="moduletable">
<div class="custom">

<div id='div-gpt-ad-1537799125700-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1537799125700-0'); });
</script>
</div>
</div>
</div>
<script>
			window.onload = function() {
				var intElemClientWidth = document.body.clientWidth;
				setCookie("__cDat",intElemClientWidth,10);
			};
    </script>
<meta http-equiv='refresh' content='0'></div>
<div class="clr"></div>

<div class="itemExtraFields">
<h3>Additional Info</h3>
<ul>
<li class="even typeRadio group1">
<span class="itemExtraFieldsLabel">Image_Position:</span>
<span class="itemExtraFieldsValue">Full</span>
</li>
</ul>
<div class="clr"></div>
</div>
<div class="itemContentFooter">

<span class="itemHits">
Read <b>387</b> times </span>
<div class="clr"></div>
</div>


<div class="clr"></div>
</div>
<div class="itemLinks">
<div style=" margin: 1rem 0; display: flex; align-items: center;">
<img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="/media/k2/users/14174.jpg" data-jchll="true" alt="" style="width: 100px; height: 100px; float: left; margin-right: 1rem; border-radius: 0;"><noscript><img src="/media/k2/users/14174.jpg" alt="" style="width: 100px; height: 100px; float: left; margin-right: 1rem; border-radius: 0;"></noscript>
<div class="authDesc" style="display: flex; font-size: .85rem; align-items: center;">
<a href="/contact/sydney-smith">Sydney Smith</a>
<p>Staff Writer, covers real estate and economic development<br /> Twitter: <a href="https://twitter.com/BizSyd" target="_blank" rel="noopener">@BizSyd</a><br /> Email: <a href="/cdn-cgi/l/email-protection#5d2e2e303429351d30343f3427733e3230" target="_blank"><span class="__cf_email__" data-cfemail="0e7d7d63677a664e63676c6774206d6163">[email&#160;protected]</span></a></p> </div>
</div>

<div class="itemTagsBlock">
<span>Tagged under</span>
<ul class="itemTags">
<li><a href="/item/tag/Kent%20County%20Land%20Bank%20Authority">Kent County Land Bank Authority</a></li>
<li><a href="/item/tag/Kent%20County">Kent County</a></li>
</ul>
<div class="clr"></div>
</div>
<div class="clr"></div>
</div>
<a href="/subscribe" style=" font-size: .8rem; display: inline-block; padding: .75rem; border: 1px solid; color: #000; font-family: Libre Franklin; font-weight: 800;">SUBSCRIBE TO MIBIZ TODAY FOR WEST MICHIGAN’S FINEST BUSINESS NEWS REPORTING <span style=" margin: 0 0 0 .5rem; border-radius: 100%; padding: 0px 5px; color: #fff; background: #000; font-weight: 800;">></span> </a>

<div class="itemAuthorLatest">
<h3>Latest from Sydney Smith</h3>
<ul>
<li class="even">
<a href="/sections/real-estate-development/kent-county-road-commission-seeks-bids-for-riverfront-property">Kent County Road Commission seeks bids for riverfront property</a>
</li>
<li class="odd">
<a href="/sections/economic-development/kent-county-commissioners-consider-dissolving-land-bank">Kent County commissioners consider dissolving Land Bank</a>
</li>
<li class="even">
<a href="/sections/real-estate-development/hinman-s-grand-rapids-hotel-project-secures-2-1-million-in-cleanup-funds">Hinman’s Grand Rapids hotel project secures $2.1 million in cleanup funds</a>
</li>
<li class="odd">
<a href="/sections/real-estate-development/second-phase-of-msu-s-grand-rapids-research-center-to-help-bring-innovation-to-market">Second phase of MSU’s Grand Rapids Research Center to help bring innovation to market</a>
</li>
<li class="even">
<a href="/sections/real-estate-development/haviland-buys-up-more-space-at-walker-s-avastar-park">Haviland buys up more space at Walker’s Avastar Park</a>
</li>
</ul>
<div class="clr"></div>
</div>

<div class="itemRelated">
<h3>RELATED ARTICLES</h3>
<ul>
<li class="even">

<a class="itemRelTitle" href="/sections/economic-development/kent-county-commissioners-consider-dissolving-land-bank">Kent County commissioners consider dissolving Land Bank</a>
</li>
<li class="odd">
<a class="itemRelTitle" href="/sections/economic-development/grand-rapids-shifts-to-working-with-nonprofits-for-tax-foreclosed-properties">Grand Rapids shifts to working with nonprofits for tax foreclosed properties</a>
</li>
<li class="even">
<a class="itemRelTitle" href="/sections/breaking-news/kent-county-to-collect-taxes-from-airbnb-bookings">Kent County to collect taxes from Airbnb bookings</a>
</li>
<li class="odd">
<a class="itemRelTitle" href="/sections/economic-development/kent-county-land-bank-pivots-to-meet-growing-demand-for-modular-housing">Kent County Land Bank pivots to meet growing demand for modular housing</a>
</li>
<li class="even">
<a class="itemRelTitle" href="/sections/breaking-news/kent-county-considers-expanding-parks-system-by-150-acres">Kent County considers expanding parks system by 150 acres</a>
</li>
<li class="clr"></li>
</ul>
<div class="clr"></div>
</div>
<div class="clr"></div>

<div class="itemNavigation">
<span class="itemNavigationTitle">More in this category:</span>
<a class="itemPrevious" href="/sections/real-estate-development/kent-county-road-commission-seeks-bids-for-riverfront-property">&laquo; Kent County Road Commission seeks bids for riverfront property</a>
</div>


<div class="itemBackToTop">
<a class="k2Anchor" href="/sections/real-estate-development/kent-county-commissioners-vote-to-dissolve-land-bank#startOfPageId26393">
back to top </a>
</div>
<div class="clr"></div>
</div>

</div></div>
</div>
</div>
</div>
</main>
</div>
</div>
</section>
</div>
<div class="g-block size-25">
<aside id="g-aside">
<div class="g-grid">
<div class="g-block size-100">
<div class="g-content">
<div class="platform-content"><div class="moduletable ">
<div class="custom">

<div id='div-gpt-ad-1537797678702-0' style='height:250px; width:300px;'>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1537797678702-0'); });
</script>
</div>
</div>
</div></div>
</div>
</div>
</div>
<div class="g-grid">
<div class="g-block size-100">
<div class="g-content">
<div class="platform-content"><div class="moduletable breaking">
<h3 class="g-title">Breaking News</h3>
<div id="k2ModuleBox722" class="k2ItemsBlock breaking">
<ul>
<li class="even">






<a class="moduleItemTitle" href="/sections/real-estate-development/kent-county-commissioners-vote-to-dissolve-land-bank">Kent County commissioners vote to dissolve Land Bank</a>
<div class="clr"></div>
<div class="clr"></div>




<div class="clr"></div>
</li>
<li class="odd">






<a class="moduleItemTitle" href="/sections/real-estate-development/kent-county-road-commission-seeks-bids-for-riverfront-property">Kent County Road Commission seeks bids for riverfront property</a>
<div class="clr"></div>
<div class="clr"></div>




<div class="clr"></div>
</li>
<li class="even">






<a class="moduleItemTitle" href="/sections/manufacturing/herman-miller-reports-strong-sales-earnings-gains">Herman Miller reports strong sales, earnings gains</a>
<div class="clr"></div>
<div class="clr"></div>




<div class="clr"></div>
</li>
<li class="odd">






<a class="moduleItemTitle" href="/sections/manufacturing/grand-traverse-plastic-acquired-by-se-michigan-pe-firm">Grand Traverse Plastic acquired by SE Michigan PE firm</a>
<div class="clr"></div>
<div class="clr"></div>




<div class="clr"></div>
</li>
<li class="even lastItem">






<a class="moduleItemTitle" href="/sections/food-agribusiness/saranac-firm-agrees-to-cease-operations-after-food-safety-violations">Saranac firm agrees to cease operations after food safety violations</a>
<div class="clr"></div>
<div class="clr"></div>




<div class="clr"></div>
</li>
<li class="clearList"></li>
</ul>
</div>
</div></div>
 </div>
</div>
</div>
<div class="g-grid">
<div class="g-block size-100">
<div class="g-content">
<div class="platform-content"><div class="moduletable ">
<div class="custom">

<div id='div-gpt-ad-1537797923370-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1537797923370-0'); });
</script>
</div>
</div>
</div></div>
</div>
</div>
</div>
<div class="g-grid">
<div class="g-block size-100">
<div class="g-content">
<div class="platform-content"><div class="moduletable ">
<div class="custom">
<div class="moduletable">
<div class="custom">

<div id='div-gpt-ad-1537798190336-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1537798190336-0'); });
</script>
</div>
</div>
</div>
</div>
</div></div>
</div>
</div>
</div>
<div class="g-grid">
<div class="g-block size-100">
<div class="g-content">
<div class="platform-content"><div class="moduletable ">
<div class="custom">
<div class="moduletable">
<div class="custom">

<div id='div-gpt-ad-1540610139465-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540610139465-0'); });
</script>
</div></div>
</div>
</div>
</div></div>
</div>
</div>
</div>
<div class="g-grid">
<div class="g-block size-100">
<div class="g-content">
<div class="platform-content"><div class="moduletable ">
<div class="custom">
<div class="moduletable">
<div class="custom">

<div id='div-gpt-ad-1537798612257-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1537798612257-0'); });
</script>
</div>
</div>
</div>
</div>
</div></div>
</div>
</div>
</div>
<div class="g-grid">
<div class="g-block size-100">
<div class="g-content">
<div class="platform-content"><div class="moduletable ">
<div class="custom">
<div class="moduletable">
<div class="custom">

<div id='div-gpt-ad-1537798853340-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1537798853340-0'); });
</script>
</div>
</div>
</div>
</div>
</div></div>
</div>
</div>
</div>
<div class="g-grid">
<div class="g-block size-100">
<div class="g-content">
<div class="platform-content"><div class="moduletable ">
<div class="custom">
<div class="moduletable">
<div class="custom">

<div id='div-gpt-ad-1537799125700-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1537799125700-0'); });
</script>
</div>
</div>
</div>
</div>
</div></div>
</div>
</div>
</div>
<div class="g-grid">
<div class="g-block size-100">
<div class="g-content">
<div class="platform-content"><div class="moduletable ">
<div class="custom">
<div class="moduletable">
<div class="custom">

<div id='div-gpt-ad-1537799308822-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1537799308822-0'); });
</script>
</div>
</div>
</div>
</div>
</div></div>
</div>
</div>
</div>
<div class="g-grid">
<div class="g-block size-100">
<div class="g-content">
<div class="platform-content"><div class="moduletable ">
<div class="custom">

<div id='div-gpt-ad-1537799376570-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1537799376570-0'); });
</script>
</div>
</div>
</div></div>
</div>
</div>
</div>
<div class="g-grid">
<div class="g-block size-100">
<div class="g-content">
<div class="platform-content"><div class="moduletable ">
<div class="custom">

<div id='div-gpt-ad-1540612011392-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540612011392-0'); });
</script>
</div></div>
</div></div>
</div>
</div>
</div>
<div class="g-grid">
<div class="g-block size-100">
<div class="g-content">
<div class="platform-content"><div class="moduletable ">
<div class="custom">

<div id='div-gpt-ad-1540611664178-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540611664178-0'); });
</script>
</div></div>
</div></div>
</div>
</div>
</div>
<div class="g-grid">
<div class="g-block size-100">
<div class="g-content">
<div class="platform-content"><div class="moduletable ">
<div class="custom">

<div id='div-gpt-ad-1540611828618-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540611828618-0'); });
</script>
</div></div>
</div></div>
</div>
</div>
</div>
</aside>
</div>
</div>
</section>
<section id="g-copyright">
<div class="g-grid">
<div class="g-block size-100">
<div id="simplemenu-4329-particle" class="g-content g-particle"> <div class="g-simplemenu-particle ">
<div class="g-simplemenu-container">
<h6>SECTIONS</h6>
<ul class="g-simplemenu">
<li>
<a target="_self" href="/sections/breaking-news" title="Breaking News">Breaking News</a>
</li>
<li>
<a target="_self" href="/sections/economic-development" title="Economic Development">Economic Development</a>
</li>
<li>
<a target="_self" href="/sections/finance" title="Finance">Finance</a>
</li>
<li>
<a target="_self" href="/sections/food-agribusiness" title="Food/Agribusiness">Food/Agribusiness</a>
</li>
<li>
<a target="_self" href="/sections/health-care" title="Health Care">Health Care</a>
</li>
<li>
<a target="_self" href="/sections/manufacturing" title="Manufacturing">Manufacturing</a>
</li>
<li>
<a target="_self" href="/sections/nonprofits" title="Nonprofits">Nonprofits</a>
</li>
<li>
<a target="_self" href="/sections/real-estate-development" title="Real Estate/Development">Real Estate/Development</a>
</li>
<li>
<a target="_self" href="/sections/small-business" title="Small Business">Small Business</a>
</li>
<li>
<a target="_self" href="/sections/talent" title="Talent">Talent</a>
</li>
<li>
<a target="_self" href="/sections/other" title="Other">Other</a>
</li>
</ul>
</div>
<div class="g-simplemenu-container">
<h6>ADVERTISING</h6>
<ul class="g-simplemenu">
<li>
<a target="_self" href="/advertise/reader-demographics" title="Reader Demographics">Reader Demographics</a>
</li>
<li>
<a target="_self" href="/advertise/editorial-calendar" title="Editorial Calendar">Editorial Calendar</a>
</li>
<li>
<a target="_blank" href="/advertise" title="Digital Ad Opportunites">Digital Ad Opportunites</a>
</li>
<li>
<a target="_self" href="/advertise/request-rates" title="Request Rates">Request Rates</a>
</li>
</ul>
</div>
<div class="g-simplemenu-container">
<h6>EVENTS</h6>
<ul class="g-simplemenu">
<li>
<a target="_blank" href="/events" title="M+A | Deals &amp; Dealmakers Awards">M+A | Deals & Dealmakers Awards</a>
</li>
</ul>
</div>
<div class="g-simplemenu-container">
<h6>ABOUT US</h6>
<ul class="g-simplemenu">
<li>
<a target="_self" href="/contact" title="Contact Us">Contact Us</a>
</li>
<li>
<a target="_self" href="/contact/staff" title="Staff Directory">Staff Directory</a>
</li>
<li>
<a target="_self" href="/careers" title="Careers">Careers</a>
</li>
</ul>
</div>
<div class="g-simplemenu-container">
<h6>SUBSCRIBE</h6>
<ul class="g-simplemenu">
<li>
<a target="_self" href="/subscribe" title="Print Subscription Rates">Print Subscription Rates</a>
</li>
<li>
<a target="_self" href="/subscribe/e-newsletters" title="Free E-newsletters">Free E-newsletters</a>
</li>
<li>
<a target="_self" href="/subscribe/subscription-questions" title="Subscription Questions">Subscription Questions</a>
</li>
<li>
<a target="_self" href="/subscribe/newsstand-sales" title="Newsstands">Newsstands</a>
</li>
</ul>
</div>
</div>
</div>
</div>
</div>
<div class="g-grid">
<div class="g-block size-100">
<div id="custom-9793-particle" class="g-content g-particle"> © 2018 MiBiz. | <a href="#">Contact Us</a> | <a href="#">Privacy</a> | <a href="#">Terms of Service</a>
</div>
</div>
</div>
</section>
</div>
<script type="text/javascript" src="/media/gantry5/assets/js/main.js?5c13ed40"></script>

<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
			
			ga('create', 'UA-1500806-1', 'auto');
			ga('send', 'pageview');
			
			</script>
</body>
</html>
